MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000301Messenger Promiscpublic22 Dec 14 23:5314 Apr 15 12:38
ReporterJNicoll 
Assigned Tomark 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionopen 
PlatformWindowsOSXPOS VersionHome 32bit
Summary0000301: MP takes AGES to start-up
DescriptionMP V2.72.0.3902 4.8.6 XP Home (32-bit)

(I finally upgraded, from V2.68.5.3631, at the start of Nov and
it's taken me ages to get around to reporting problems, sorry.)

MP now takes AGES to start; almost every time it's somewhere
between 3 and 4 minutes with one cpu core running flat-out. I
don't know how long it took before, but I never found it 'too
long' - so maybe 30 seconds?

Once or twice I've thought it was quicker (though still slower
than my old V2.68) though it might be that I was distracted &
didn't realise the usual amount of time had passed.

I've also noticed that the activity (expire?) that happens
just after midnight can be excruciatingly slow (I think it
depends on how busy the machine otherwise is). But this makes
me wonder if the occasional not so slow start-up might be
one where MP was shut down immediately after a midnight+
activity completed. Often I don't do that though, shutting
down hours later.

And what IS happening at midnight+ ? I do not have expiry
configured on anywhere, so presumably what's being done is
group-folder compaction.

I know that somewhere in the v2.68 -> v2.72 set of changes
were some made to how MP creates indexes. Is this what's
causing all the delay? How would I diagnose it?
Steps To ReproduceStart MP.

TBH This tends to make me loathe to shutdown MP...
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000395)
mark (administrator)
04 Mar 15 14:20

A number of performance improvements have been made in 2.73.1. Perhaps when this release is available you could give it a try and feedback whether or not it's helped?
(0000401)
JNicoll (reporter)
07 Mar 15 00:37

Oh, I will...
(0000404)
JNicoll (reporter)
11 Mar 15 09:15

I've half-solved this ;-) The delay was clearly split into two halves - wait for ages for MP's main window to get displayed first, and almost immediately afterwards wait ages more while an expire got done. Sometimes, presumably when an expire had already been done that day, the latter delay didn't happen.

I noticed eventually that I had an 'Open' filter enabled - one which will take effect against any group. The handful of these filters that I have are usually disabled and turned on only for doing something specific for a single group, and then turned off again. Having turned it off, my impression is that the 'expiry' process (while still quite slow) is no slower than it was before. I still wish it didn't happen in one great big chunk of activity - a bit more multi-tasking would be useful... It might be better if it were split into 'expire' (none of my groups have that enabled) and compaction. Obviously I do see the advantage of compaction but I think I'd be happier if it happened a few groups at a time any time that the machine was relatively idle.

The initial delay between starting MP and seeing the main window open is (now that the filter issue is solved) a pretty constant 100 seconds. In my attempt yesterday to install 2.73.1, just before I did so I deliberately set MP into 'offline' mode, shut it down, made sure that none of my scheduled tasks which consume lots of cpu were about to start, and started MP. I also did this later after backing out 2.73.1. In both cases MP 2.72 took 100 seconds to get to the main window open stage. Both then didn't do an expire and - being offline - didn't do anything else.
(0000405)
JNicoll (reporter)
14 Apr 15 12:38

Sorry for not updating this sooner. Both my XP machines have had catastrophic disk failures in the last ten days (it's complicated and somewhat worrying) and although there's an outside chance one (which had SCSI drives in it) might yet come back to life if the main drive turns out to be mechanically ok but just have a fried PCB - though I don't expect that to be so - the other machine's disk has a fatally corrupted NTFS that chkdsk won't repair... So I'm now using a 64bit i7 machine with W8.1 and an SSD, so startup delays have vanished.

- Issue History
Date Modified Username Field Change
22 Dec 14 23:53 JNicoll New Issue
03 Mar 15 12:47 mark Status new => acknowledged
04 Mar 15 14:20 mark Note Added: 0000395
04 Mar 15 14:20 mark Assigned To => mark
04 Mar 15 14:20 mark Status acknowledged => feedback
07 Mar 15 00:37 JNicoll Note Added: 0000401
07 Mar 15 00:37 JNicoll Status feedback => assigned
11 Mar 15 09:15 JNicoll Note Added: 0000404
14 Apr 15 12:38 JNicoll Note Added: 0000405


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker